# ビルドエラー：このサービスのキーの最大数にすでに達しています

iOSビルドが失敗することは一般的ではありませんが、ビルドプロセス中に使用できない既存の通知キーがある場合に発生する可能性があります。

#### 原因:

Apple Developerアカウントに既存の通知キーがあるためです。AdaloはiOSアプリ内のプッシュ通知に1つのキーが必要で、これを選択的に使用することはできません。

#### 解決方法:

AdaloがこのアプリをTestFlightにアップロードできるようにするために、通知キーを削除してください。これを行うには、次の手順に従ってください：

1. [Apple Developerアカウント](https://developer.apple.com/account/resources/authkeys/list)にログインします。
2. "アカウント"に移動します。
3. "Certificates"、次にIdentifiers and Profiles、そして左側のキーを選択します。
4. Apple Push Notificationsサービス（APNs）を使用するキーにアクセスを取り消します。
5. Adaloに戻り、iOSアプリの新しいビルドを作成します。これにより新しいキーが生成され、続行できるはずです。


---

# Agent Instructions: Querying This Documentation

If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter:

```
GET https://help.adalo.com/ja/testing-your-app/publishing-to-the-apple-app-store/submit-your-build-to-the-app-store/build-error-you-have-already-reached-the-maximum-allowed-number-of-keys-for-this-service.md?ask=<question>
```

The question should be specific, self-contained, and written in natural language.
The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
