App Rejected: Add Permission Text to Your iOS Build

Apple Publishing expects end-users of apps to know why their Camera, Location, and Photo Library. Apple may reject your app if the use case for this data is not clearly mentioned, hence we encourage you to add as much detail as possible. At any time, you can update this in your iOS Publishing Settings and push a new built to Testflight to see the changes.

Possible Causes:

  1. Permissions not set: If you did not enter any text into the permission settings of your build, Apple will reject your app.

  2. Permissions text not clear: If your permission text does not clearly state why you need to access the permission, the app may be rejected by Apple. Please be as detailed as possible to ensure users know why you need access to each permission.

Resolution:

  1. Permissions need to be updated:

    1. Go to the Publish section of the left panel.

    2. Go to the iOS sub-section, and click Update Settings under iOS Export Settings.

    3. Add your Apple Credentials from your Apple Developer account. For more information, please refer to Help Docs | Publishing to the Apple App Store.

    4. Click next.

    5. In the app request permission section, please add details that you would like to be shown in the permission request while using the app. There are three sections, Camera, Location and Photo Library. Please fill all sections as these are required.

    6. Click Save iOS Settings.

    7. Push a new build to Testflight and resubmit.

Apple reviews are done by humans and occasionally you may submit a new build and get a different result from a different reviewer with no changes to the app. If you believe your permissions are detailed enough, please try creating a new build to submit for review.

Still Need Help?

If you're stuck, don't worry! Please first reach out to Apple support for more details on the issue.

If you are still unable to resolve, reach out to our support team for further assistance with the details below.

  1. Include Steps Taken: Let us know what troubleshooting steps you've already tried.

  2. Provide any information you received from Apple.

Last updated